3305 Main Street Ste 019 Vancouver, WA 98663

Does Liberty Reports for Sage 100 Contractor support the SQL Server Version?

Background

The purpose of this article is to make you aware of the status of Liberty Reports as is relates to compatibility with Sage 100 Contractor v20 (the SQL release).

As you may already be aware, the release of Sage 100 Contractor v20 is an extensive upgrade because the underlying database engine changes (to Microsoft SQL Server). As of April 5th, 2016, there is a version of Liberty Reports for Sage 100 Contractor that works with the version 20 release.

Frequently Asked Questions
  • What version of Liberty Reports is required to work with Sage 100 Contractor v20? Liberty Reports version 1.0.68 for Sage 100 Contractor. Click here to access the download page.
  • Will my existing Liberty Report designs work with the new database? Yes, with the new release, nearly all of your existing reports (designed with prior versions using the legacy database) will continue to function with the new SQL Server database. Depending on the specific design process used to build your reports, it is possible that some minor changes will be needed in order to be compatible with the SQL Server database.
  • Will reports that I create using the SQL Server database still work with the legacy database? No, the query syntax that is used by Liberty Reports when building reports with the SQL Server database is not compatible with the legacy database. If you need to continue to support both databases, design work should be performed while connected to a legacy database.

If you have any questions or concerns about the upcoming changes or release plan, please let us know.